LockDown Browser crashes after I login to the Central Authentication Service (CAS) on macOS


Issue

I'm on macOS and LockDown Browser crashes after I login to the Central Authentication Service (CAS). I have a security key in Duo and complete multi-factor authentication with Touch ID.

Environment

LockDown Browser

Resolution

Temporarily remove your enrolled security keys from Duo multi-factor authentication.

  1. If you are already signed in to Central Authentication Service (CAS) with Duo, open a private or incognito window first.
  2. Go to https://login.umd.edu.
  3. Select LOGIN TO SINGLE SIGN-ON and the Central Authentication Service (CAS) should appear. If you're directed to a page saying You are logged in as:, open a private or incognito window and repeat these steps.
  4. Authenticate with CAS and stop when the Duo prompt appears.
  5. Select Other options from the Duo prompt. A list of Other options to log in will appear.
  6. Select Manage devices from the list. A Verify your identity before managing devices prompt will appear.
  7. Select one of your MFA devices and complete Duo authentication. The device management page will appear.
  8. Make sure you have at least one device that is not a Security key. If you only have a security key, select Add a device and enroll a new device in Duo.
  9. For each of the Security keys listed on the page, do the following:
    1. Select Edit. A dropdown menu will appear.
    2. Select Delete. A confirmation message will appear.
    3. Select the Delete <security-key-name> button.
  10. Close the browser window.

Please reattempt using LockDown Browser.

Cause

The LockDown Browser vendor, Respondus, is aware of an issue impacting LockDown Browser version 2.1.3.00 that causes it to crash when macOS requires Bluetooth during Duo multi-factor authentication for a security key.