Microsoft 365: "AADSTS90019: No tenant-identifying information found in either the request or implied by any provided credentials." error message


Issue

I am trying to login to Microsoft 365 to download the Office applications (Word, Excel, PowerPoint, etc.), but I cannot log in. I am receiving a AADSTS90019: No tenant-identifying information found in either the request or implied by any provided credentials. error message when signing in.

I'm using the Safari web browser on my Mac, and I am autofilling the username and passphrase using iCloud Keychain. 

Environment

Microsoft 365.

Resolution

Make sure you are using your UMD email address when authenticating to Microsoft 365. You may need to manually enter your UMD email address and passphrase when signing in, instead of using your browser's autofill. 

Cause

When Safari is auto filling the Directory ID passphrase, it is replacing the username (DirectoryID@umd.edu) with only your Directory ID. As a result, Microsoft does not recognize the account username.