MyE911 Username and Password Not Working


Issue

Launched MyE911 and entered my email address and the password provided in Installing MyE911 into the fields. Received an error message that the username/password is invalid.

Environment

  • MyE911
  • Cisco Jabber
  • Webex

Resolution

In order to access your softphone, you will need to submit a form requesting access to the service.

Cause

The softphone access had not been provisioned yet, so the credentials were not found.